灵客论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 11|回复: 0

[原创] 世外桃源乙太指标分享,东方财富通达信通用。

[复制链接]
  • TA的每日心情
    开心
    昨天 21:02
  • 签到天数: 52 天

    [LV.5]常住居民I

    106

    主题

    265

    帖子

    911

    积分

    高级会员

    Rank: 4

    灵客宝
    96
    金钱
    454
    在线时间
    38 小时
    注册时间
    2019-3-30
    发表于 2019-5-15 22:38:05 | 显示全部楼层 |阅读模式
    N:=5;
    C0:=(H+L+C)/3;
    a1:=HHV(C0,n);
    a2:=LLV(C0,n);
    a3:=a1-a2;
    a4:=EMA((C0-a2)/a3,2)*100;
    b1:=HHV(C0,4*n);
    b2:=LLV(C0,4*n);
    b3:=b1-b2;
    b4:=EMA((C0-b2)/b3,2)*100;
    C1:=HHV(C0,16*n);C2:=LLV(C0,16*n);C3:=C1-C2;
    C4:=EMA((C0-C2)/C3,2)*100;
    短期:a4,colorred,linethick2;
    中期:b4,colorwhite,linethick1;
    长期:C4,colorcyan,linethick1;
    底部线:10,COLORFFFF00;
    收发线:80,COLORFFFF00;
    牛碧线:90,COLORFFFF00;


    VARC:=(ZIG(3,6)>=REF(ZIG(3,6),1)) AND (REF(ZIG(3,6),1)<=REF(ZIG(3,6),2)) AND (REF(ZIG
    (3,6),2)<=REF(ZIG(3,6),3))AND (REF(ZIG(3,6),3)<=REF(ZIG(3,6),4));
    VARD:=(ZIG(3,6)<=REF(ZIG(3,6),1)) AND (REF(ZIG(3,6),1)>=REF(ZIG(3,6),2)) AND (REF(ZIG
    (3,6),2)>=REF(ZIG(3,6),3))AND (REF(ZIG(3,6),3)>=REF(ZIG(3,6),4));
    STICKLINE((VARC=1),(短期),短期+30,4,0),colorred;
    DRAWTEXT((VARC=1),(短期-0),'买'),colorred;
    STICKLINE((VARD=1),(短期-2),8,4,0),Color00FF00;
    DRAWTEXT((VARD=1),(短期+5),'注意'),Color00FF00;
    VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
    VarF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
    ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
    Var10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
    ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
    Var11:=VarF<REF(Var10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
    DRAWTEXT(Var11 AND COUNT(Var11,30)=1,50,'大资金活动'),linethick1,COLORff00ff;
    STICKLINE(Var11 AND COUNT(Var11,30)=1,50,10,5,0),colorff00ff;
    Var12:=(HIGH+LOW+CLOSE)/3;
    Var13:=(Var12-MA(Var12,14))/(0.015*AVEDEV(Var12,14));
    Var14:=(Var12-MA(Var12,70))/(0.015*AVEDEV(Var12,70));
    Var15:=IF(Var13>=150 AND Var13<200 AND Var14>=150 AND Var14<200,10,0);
    Var16:=IF(Var13<=-150 AND Var13>-200 AND Var14<=-150 AND Var14>-200,-10,Var15);
    Var17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
    Var18:=100-ABS(Var17);
    Var19:=IF(Var18<90,Var18,100);
    Var1A:=IF(VarE>0,VarE,0);
    Var1B:=IF(Var14>=200 AND Var13>=150,15,IF(Var14<=-200 AND Var13<=-150,-15,Var16))+60;
    Var1C:=Var1A>48 AND Var1B>60 AND Var19<100;
    DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,50,'换手增加'),linethick1,COLORffcc66;
    STICKLINE(Var1C AND COUNT(Var1C,30)=1,50,10,5,0),colorffcc66;


    QQ图片20190515223600.png

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    展开

    手机版|小黑屋|灵客社区
    灵客外汇论坛-全国最大的外汇ea论坛交流社区

    GMT+8, 2019-5-26 05:34 , Processed in 1.163086 second(s), 36 queries .

    Powered by Discuz! X3.4

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表