灵客

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 108|回复: 1

[探讨] 编写指标公式时常用的语句

[复制链接]

该用户从未签到

345

主题

739

帖子

2613

积分

金牌会员

Rank: 6Rank: 6

灵客宝
52
金钱
1770
在线时间
131 小时
注册时间
2018-7-12

优秀版主

发表于 2018-11-1 10:27:34 | 显示全部楼层 |阅读模式
一、提供以下常用语句,以方便朋友们编写公式时参考使用:

1)今收盘对于N日内最低收盘价的涨幅(%)(c-llv(c,n))/llv(c,n)*100;

2)今收盘价对于N日最高收盘价的跌幅(%)(HHV(C,N)-C)/HHV(C,N)*100;

3)股价在过去N日内运行空间的相对位置 (C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;

4)股价上方N1%至N2%处的筹码(%)

aa:=winner(c+c*n2/100)*100;

bb:=winner(c+c*n1/100)*100;

aa-bb

5)股价下方N1%至N2%处的筹码(%)

(winner(c-c*n1/100)-winner(c-c*n2/100))*100;

6)收盘价N%处的套牢盘 100-(winner(c*N/100))*100;

7)收盘价N%处的获利盘 winner(c*N/100)*100;

8)下影线 (MIN(O,C)-L)/L*100;

9)上影线 (h-max(o,c))/max(o,c)*100;

10)本周期的涨跌幅 (c-ref(c,1))/ref(c,1)*100;

11)振幅 (h-l)/l*100;

12)均线金叉(M.N为均线周期) cross(ma(c,m),ma(c,n))

13)均线多头排列

a1:=ma(c,n1);

a2:=ma(c,n2);

a3:=ma(c,n3);

a4:=ma(c,n4);

count(a1>a2 and a2>a3 and a3>a4,3);

14) 均线空头排列

a1:=ma(c,n1);

a2:=ma(c,n2);

a3:=ma(c,n3);

a4:=ma(c,n4);

count(a1<a2 and a2<a3 and a3<a4,3);

15)N日均线向下

aa:=ma(c,n);

bb:=ref(aa,2);

aa<bb

16)向前N日至M日出现过均线死叉(P1<2)

aa:=ma(c,p1);

bb:=ma(c,p2);

cc:=ref(cross(bb,aa),n);

count(cc,m);

17)今日成交量大于N日以来的均量 vol>MA(VOL,N);

18)低位密集

A1:=COST(85);

A2:=COST(15);

A3:=A1-A2;

A4:=(A1+A2)/2;

A5:=A3/A4*100<10;

B1:=HHV(H,120);

B2:=LLV(L,120);

B3:=B1-B2;

B4:=(A4-B2)<B3/2;

A5 AND B4;

19)换手率 VOL/CAPITAL*100;

20)N日盈亏

V1:=VOL/SUM(VOL,N);

V2:=dma(CLOSE,V1);

V3: (CLOSE-V2)/V2*100;

21)强势整理

{参数M、N分别代表周期和幅度 m:1 20 2 n:1 20 5}

a1:=abs(close-open)/open<0.015;

a2:=count(a1,m)=m;

a3:=ref(o,m)<ref(close,m) and

ref(close,m)/ref(close,m+1)>1+n/100;

a2 and a3

22)高开大阴

{参数m,n分别代表幅度 m:1 10 4 n:1 20 5}

OPEN>CLOSE AND OPEN/REF(C,1) >= 1+M/100 AND CLOSE/OPEN<=1-N/100

23)低开大阳线

{参数m,n分别代表幅度 m:1 10 4 n:1 20 7}

OPEN<CLOSE AND OPEN/REF(C,1) <= 1-M/100 AND CLOSE/OPEN>=1+N/100

二、编写公式时常用的通式(这是在网上摘录的,仅供参考)

常用的通式:

{设A,B,R为三条曲线;N,M等为参数。如:A:ma(c,N) ; B:=ma(c,M); R:=c/ref(c,1)-1;等。。。}

(一).曲线在N天内的平均变化率

Fa:=(A/ref(A,N)-1)/N; Fb:=(B/ref(B,N)-1)/N; Fr:=(R/ref(R,N)-1)/N;

(二).变动角

∮a:=atan(Fa);    ∮b:=atan(Fb);  ∮r:=atan(Fr);

(三).曲线上相距N天的两点的连线的斜率

Ka:=(A-ref(A,N))/N;   Kb:=(B-ref(B,N))/N; Kr:=(R-ref(R,N))/N;

(四).倾角

∠a:=atan(Ka);   ∠b:=atan(Kb);   ∠r:=atan(Kr);

(五).交叉点

Cab:=cross(A,B);{交叉} Jab:=longcross(A,B,N);{维持 -交叉}

JYa:=between(A,N,M);{介于} FWa:=range(A,N,M);{范围}

(六).下拐点(由下向上转)

xD1:=llvbars(A,N)=M;{以N日最低点}

xD2:=ref(count(A-ref(A,1)<=0,N)=N,M) and count(A-ref(A,1)>0,M)=M;{以M日变化量的正负}

xD3:=ref(count(∠a-ref(∠a,1)<=0,N)=N,M) and ∠a>0;{以当日变化角的正负}

(七).上拐点(由上向下转)

sD1:=hhvbars(A,N)=M;{以N日最低点}

sD2:=ref(count(A-ref(A,1)>=0,N)=N,M) and count(A-ref(A,1)<0,M)=M;{以当日变化量的正负}

sD3:=ref(count(∠a-ref(∠a,1)>=0,N)=N,M) and ∠a<0;{以当日变化角的正负}

(八).位置(求得交叉点/拐点到当前的周期)

Wz1:=barslast(Cab);{第一(交叉)点的位置}

Wz2:=ref(Wz1,Wz1+1)+Wz1+2;{第二(交叉)点的位置}

Wz3:=ref(Wz1,Wz2+1)+Wz2+2;{第三(交叉)点的位置}

Wz4:=ref(Wz1,Wz3+1)+Wz3+2;{第四(交叉)点的位置}

Wz5:=ref(Wz1,Wz4+1)+Wz4+2;{第五(交叉)点的位置}

{Wzn:=ref(Wz1,Wz(n-1)+1)+Wz(n-1)+2;}

(九).曲线A叠加曲线B

F:=A/ref(A,1)-1;{A的变化率}

Js:=ref(B,barscount(c));{叠加位置(初始)}

DJsum(F,0)+1)*Js;{叠加曲线(初始位置)}

Jd:=ref(B,barslast(条件));{叠加位置(定点)}

Dj:=(sum(F,0)+1)*Jd;{叠加曲线(预定位置)}


该用户从未签到

4

主题

222

帖子

805

积分

高级会员

Rank: 4

灵客宝
88
金钱
407
在线时间
41 小时
注册时间
2018-10-24
发表于 2018-11-3 20:12:57 | 显示全部楼层
回复
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

展开

手机版|小黑屋|灵客社区
灵客外汇论坛-全国最大的外汇ea论坛交流社区

GMT+8, 2019-3-22 16:02 , Processed in 0.207649 second(s), 29 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表